Subject: Re: keep support for gcc 2.95 in NetBSD 1.6.x?
To: None <>
From: Joerg Sonnenberger <>
List: pkgsrc-users
Date: 12/23/2006 16:59:53
On Sat, Dec 23, 2006 at 11:05:08AM +0100, Klaus Heinz wrote:
> Joerg Sonnenberger wrote:
> > On Fri, Dec 22, 2006 at 12:20:00AM +0100, Klaus Heinz wrote:
> > > are we supposed to keep existing patches for compatibility with gcc 2.95?
> > 
> > As other platforms lack C99 compilers, it would be appreciated.
> Ah, you want to say that we should keep the package buildable with gcc
> 2.95 because that's the only compiler available on some platforms?

No, more like "The commercial compilers of some platforms have a
similiar feature set".

> This is the crucial point. There are some patches for compatibility with
> gcc 2.95 but they do not apply anymore and I would have to build with
> this compiler to identify how to change them and whether there are new
> patches necessary.

What I wanted to say is: don't bother too much.