Subject: Re: apache and mod_perl
To: Matthias Scheler <>
From: Emmanuel Dreyfus <>
List: pkgsrc-users
Date: 11/21/2006 20:21:16
Matthias Scheler <> wrote:

> > A strange problem with apache and mod_perl from pkgsrc:
> > I had to add -lpthread in httpd link command, otherwise loading
> > mod_perl caused a core dump.
> [...]
> > I don't know how this can be correctly fixed.
> You could use the "apache2" package instead (which is better maintained
> externally anyway). The "httpd" binary in that package is linked with
> "libpthread" anyway.

For various reasons, I need apache 1.3 for this machine. If www/ap_perl
cannot work with www/apache, then it should at least issue a warning.
Providing a package that will just dump a core is pointless.

Emmanuel Dreyfus