Subject: Re: problem building bmake, NetBSD 3.0, i386; request to update net/p5-Net-Z3950;
To: None <>
From: Juan Zuluaga <>
List: pkgsrc-users
Date: 09/24/2006 23:01:07
> On NetBSD 3.0, no need to use pkgsrc's bmake, use
> built-in make instead.

OK. So I tried, still follwing the instructions at

bash-3.00# cd /usr/pkgsrc/net/p5-Net-Z3950-ZOOM/
bash-3.00# ls
DESCR     Makefile  PLIST     distinfo  work
bash-3.00# pkglint -e
not a valid mail address.
0 errors and 1 warnings found.
bash-3.00# make
===> Checking for vulnerabilities in
=> Checksum SHA1 OK for Net-Z3950-ZOOM-1.11.tar.gz.
=> Checksum RMD160 OK for Net-Z3950-ZOOM-1.11.tar.gz.
===> Patching for Net-Z3950-ZOOM-1.11
===> Creating toolchain wrappers for
===> Configuring for Net-Z3950-ZOOM-1.11
===> Building for Net-Z3950-ZOOM-1.11
make: cannot open Makefile.

make: stopped in
*** Error code 2

make: stopped in /usr/pkgsrc/net/p5-Net-Z3950-ZOOM
===> There was an error during the ``build'' phase.
===> Please investigate the following for more
===>      * log of the build
===>      *
*** Error code 1

make: stopped in /usr/pkgsrc/net/p5-Net-Z3950-ZOOM

I guess this is due to the fact of p5-Net-Z3950-ZOOM
being a perl module. 
What should I add to the command to make it compile? 

(before, I tried to install it via perl -MCPAN etc; it
seems to install ok, but the cgi complains).  

> If you want to use pkgsrc's bmake, install
> pkgtools/bootstrap-mk-files
> first.
> --
> "Of course I love NetBSD":-)
> OBATA Akio /
Comentarios sobre politica, sociedad y ciencia social.

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around