Subject: Openldap client fails to find pkg for openssl
To: None <>
From: Loren M. Lang <>
List: pkgsrc-users
Date: 09/24/2006 21:17:02
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

I have a built-in openssl library on my linux box installed under /usr,
but it's a little dated so I installed security/openssl from pkgsrc and
set PREFER.openssl to pkgsrc in mk.conf.  Following that I installed
heimdal which had no issues and ldd reveals that it is using openssl
under /usr/pkg.  Next I tried installing openldap-client, but had it
fail trying to find openssl.  There is a bug in the openssl headers in
/usr/include and configure tried using them so I moved them out of the
way and tried to re-install it.  The configure script failed again still
looking under /usr/include.  Why isn't it looking under
/usr/pkg/include, I thought PREFER.openssl =3D pkgsrc should resolve that.
Loren M. Lang

Public Key:
Fingerprint: CEE1 AAE2 F66C 59B5 34CA  C415 6D35 E847 0118 A3D2

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.1 (GNU/Linux)