Subject: mk/tools/
To: None <>
From: OBATA Akio <>
List: pkgsrc-users
Date: 09/11/2006 23:29:11

in mk/tools/

_TOOLS_DEP.gettext-tools=	{gettext>=0.10.36,gettext-tools>=0.14.5}


TOOLS_DEPENDS.msgfmt?=	${_TOOLS_DEP.gettext-tools}:../../devel/gettext-tools

So, if USE_TOOLS = msgfmt, and neither gettext nor gettext-lib are installed,
then try to install gettext>=0.10.36 and go to devel/gettext-tools,

=> Registering installation for gettext-tools-0.14.6
gettext-tools-0.14.6 requires installed package gettext-lib-0.14.6
gettext-tools-0.14.6 requires installed package pkg_install-info-4.5nb3
=> Checking for missing run-time search paths in gettext-tools-0.14.6
=> Checking for work-directory references in gettext-tools-0.14.6
=> Checking file-check results for gettext-tools-0.14.6
===> Cleaning for gettext-tools-0.14.6
ERROR: [] A package matching ``gettext>=0.10.36'' should
ERROR:     be installed, but one cannot be found.  Perhaps there is a
ERROR:     stale work directory for ../../devel/gettext-tools?
*** Error code 1

Should change to ?
_TOOLS_DEP.gettext-tools=	{gettext-tools>=0.14.5,gettext>=0.10.36}

And how about ?

_TOOLS_USE_MSGFMT_SH!=                                                  \
        if ${PKG_ADMIN} pmatch "gettext>0.10.35"                        \
                        gettext-${_TOOLS_VERSION.msgfmt:Q}; then        \
                ${ECHO} no;                                             \
        else                                                            \
                ${ECHO} yes;                                            \

"Of course I love NetBSD":-)
OBATA Akio /