Subject: ruby related pkgs don't build (pthread ?)
To: None <>
From: Martin S. Weber <>
List: pkgsrc-users
Date: 09/08/2006 20:56:32

after the update to ruby 1.8.5 some ruby related packages no
longer build for me. The affected packages are:

 ruby-sqlite3 ruby-racc rubygems ruby-eruby ruby-rdtool

environment is a pkgsrc-HEAD of tonight plus NBSD 4.99.1 i386.

The failure pattern is like this (extracted from ruby-sqlite3)

=> Required installed package ruby18-base>=1.8.5: ruby18-base-1.8.5 found
===> Overriding tools for ruby18-sqlite3-1.1.0nb1
===> Extracting for ruby18-sqlite3-1.1.0nb1
===> Patching for ruby18-sqlite3-1.1.0nb1
===> Creating toolchain wrappers for ruby18-sqlite3-1.1.0nb1
===> Configuring for ruby18-sqlite3-1.1.0nb1
===>  Running setup.rb to configure
config: unknown option --enable-pthread
Try 'ruby setup.rb --help' for detailed usage.
*** Error code 1

make: stopped in /src/pkgsrc/databases/ruby-sqlite3
*** Error code 1

make: stopped in /src/pkgsrc/databases/ruby-sqlite3
*** Error code 1

make: stopped in /src/pkgsrc/databases/ruby-sqlite3

All the noted packages fail like this.

This is probably related to ...

$ ruby -ve 'require "rbconfig"; include Config; puts "#{CONFIG["configure_args"]}"'
ruby 1.8.5 (2006-09-06) [i386-netbsdelf]
 '--enable-shared' '--enable-install-doc' '--with-ssl-include=/usr/include' 
 '--with-ssl-lib=/usr/lib' '--enable-pthread' 
 '--program-suffix=18' '--prefix=/usr/pkg' '--host=i386--netbsdelf' 
 '--mandir=/usr/pkg/man' 'host_alias=i386--netbsdelf' 'CC=cc' 
 'CFLAGS=-O2 -march=pentium3 -I/usr/include' 
 'LDFLAGS=-L/usr/lib -Wl,-R/usr/lib -Wl,-R/usr/pkg/lib' 'CPPFLAGS=-I/usr/include'

Funny enough, I've successfully built these ruby packages:

ruby18-base-1.8.5   Ruby 1.8 based release minimum package
ruby18-postgresql-0.7.1nb7 Ruby extension for postgresql
ruby18-curses-1.8.5 Ruby extension to curses library
ruby18-ncurses-1.0nb1 Ruby interface to ncurses
ruby18-readline-1.8.5 Ruby extension to readline library
ruby18-gnuplot-2.2  Ruby interface to a gnuplot process
ruby-1.8.5          Wrapper package for Ruby programming language
ruby18-tk-1.8.5     Ruby interface to the Tk widget set including Tcl/TK library