Subject: net/freeradius fails to build rlm_sql_mysql under DragonFly BSD
To: None <>
From: Morgan Reed <>
List: pkgsrc-users
Date: 09/01/2006 12:19:53
I've been attempting to build net/freeradius with mysql support under
DragonFly BSD (current CVS pkgsrc tree), when I run 'bmake
PKG_OPTIONS.freeradius="mysql"' the build proceeds without any errors,
however if (post-build) I run 'ls -aR work/freeradius-1.1.2 | grep
mysql' I don't find,, etc. and after
a 'bmake install' and enabling mysql support in the config, freeradius
fails to start reporting;

Error: rlm_sql (sql): Could not link driver rlm_sql_mysql: Shared
object "" not found, required by "radiusd"
Error: rlm_sql (sql): Make sure it (and all its dependent libraries!)
are in the search path of your system's ld.

I've found some references to errors like that above online but all of
them were at compile time whereas it occurs at runtime in my case,
I've tried some of the suggestions I found online with no joy.

I've done the same build under NetBSD without issue (with the current
CVS pkgsrc tree and also an older snapshot).

I also attempted to build using 'bmake PKG_OPTIONS.freeradius="mysql
pam"'; the pam modules were built correctly, but again the mysql
modules failed to build.

Not sure what's going on, the deps are found properly (all
dependancies were built prior to attempting a build of freeradius.),
the configure commands being issued include the appropriate option

Any assistance would be greatly appreciated.

Best Regards,
Morgan Reed