Subject: Problems/Suggestions after reinstall
To: None <>
From: Eye of the Beholder <>
List: pkgsrc-users
Date: 07/27/2006 13:17:16

I had been using a i386 netbsd-current which worked fine.
I thought that i should install the amd64 port to see if there is any
perfomance gain. So, i installed the amd64 base system and tried to
recompile the whole system. During that, i have faced the following

I didn't post in pkgsrc-bugs because they may not necessarily be bugs,
but maybe i did something stupid.

So, the problems are the following:

checking build system type... x86_64-unknown-netbsd3.99.22
checking host system type... x86_64--netbsd

I get this in all the packages. Do you get it also ?
I don't mind the "unknown" since it doesn't really matter
but it would be better if it was something else.
Anyway this is a minor.

All programs using libX11 or any other lib from xorg-libs crash with
signal 10. I posted this in current-users and got the reply to use
"-fno-strict-aliasing" which worked and now everything works.

I compiled the xorg-libs in netbsd-i386 which works fine, and in
netbsd-amd64 with a amd cpu which also works fine. It only crashes
on netbsd-amd64 with a intel cpu.

I have in mk.conf
CFLAGS+= -march=nocona -pipe
CXXFLAGS+= -fno-strict-aliasing

but xorg-libs didn't honour it so i had to put it at DefaultCCOptions

I don't know if anyone had this problem so it may be a patch for it.

3) After, messing with X11PREFIX,X11ROOT_PREFIX,X11BASE in order to
install the Xorg to /usr/X11R6 with no luck (the best i could do
is install it in /usr/pkg when X11ROOT_PREFIX is blank) i installed
it in the NetBSD default /usr/pkg/xorg prefix (i read the bug report
about every package needs to be in /usr/pkg) and symlinked /usr/X11R6
and /etc/X11 to /usr/pkg/xorg and it works perfectly.

I found though that some X11 packages don't have USE_X11BASE or
something like that and install in /usr/pkg.
These are : Xrender, xcursor, Xrandr, Xft2, Xterm
All these have some X11 files (like include/X11/extensions)
and when installed in /usr/pkg some packages say that "Y extension
not found"

I put USE_X11BASE=yes on their makefile and did installed them
in /usr/pkg/xorg fine. I want to ask if this is done on purpose ?
Do they belong in /usr/pkg ?

x11/gtk installs in /usr/pkg/xorg while x11/gtk2 installs in
/usr/pkg. Is this normal ?

5) dnsmasq installs fine in /usr/pkg and dnsmasq.conf is copied
in /usr/pkg/etc but dnsmasq has /etc/dnsmasq.conf hardwired
so it doesn't read the proper file.
I guess there are 3 solutions to this:
a) copy /usr/pkg/etc/dnsmasq.conf to /etc (against pkgsrc
b) modify /etc/rc.d/dnsmasq to include
command_args="-C /usr/pkg/etc/dnsmasq.conf"
c) modify dnsmasq's source to change the hardwired path

6) sylpheed-claws is version 1.0.4 in pkgsrc while there
is a way newer version

7) mjpegtools, wmaker configure say that mmx is disabled.
Is this normal ?

8) mplayer-fonts contains iso8859-{1,2} from the mplayer
website. It would be nice if the iso8859-7 font from the
website is included too

9) mplayer makefile has the xvid option only for i386 while xvidcore
compiles fine in amd64 too.

10) when i try to configure mplayer i get "cpu not recognised or
compiler too old".

The fix is change some occurances of "x86" to "x86 || x86_64" in
the configure.

11) cdrdao's configure checks for lame and uses it if found
but there is no lame option or dependency in the makefile.
Also, there is another problem which i describe in 12)

12) Some packages' configure doesn't find already installed
packages. This happens for example in the following:

a) Cdrdao which doesn't find mp3/ogg support
b) sox 
c) dvdauthor which doesn't find png

I will try to describe the problem/solution

when i do "make configure" in dvdauthor i get

checking for zlibVersion in -lz... yes
checking for png_sig_cmp in -lpng... no
configure: error: You must have libpng(-devel) installed
*** Error code 1

While libpng exists.

I copied the relevant conftest.c from the configure
and compiled it manually using the same options (taken
from config.log) and it compiled fine, so i did
"make PKG_DEBUG_LEVEL=2 configure" and copied the
whole configure line and tried to see what is wrong.

What i have found is that in all cases the only wrong
was the PATH variable and the fault is in the "wrapper"

I hashed the "PREPEND_PATH" in mk/wrapper/
and did "make configure" again. The result is the following

checking for zlibVersion in -lz... yes
checking for png_sig_cmp in -lpng... yes

I haven't messed with the wrappers to see what is wrong
about them but in the packages i tested when i remove the
wrapper path thus disabling the wrappers the problem goes away.

Has anyone else faced this ?

I am sorry for my long post and if some questions
are easy/stupid.

If any of the things i describe require more info
or a pr, i can do it.

Thank you for your time.