Subject: security/tor
To: None <>
From: Jan Danielsson <>
List: pkgsrc-users
Date: 07/09/2006 15:19:24
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hello all,

I wanted to give TOR a try, so I installed it:

# cd /home/pkgsrc/pkgsrc/seciruty/tor
# make install


Then I copied the sample rc.d/tor to /etc/rc.d

   I also installed www/privoxy as recommended. AFAICT, privoxy works.
But when I run:

# /etc/rc.d/tor start

=2E.I get:
Jul 09 15:15:42.676 [notice] Tor v0.1.1.21. This is experimental
software. Do not rely on it for strong anonymity.
Jul 09 15:15:42.677 [warn] options_init_logs(): Can't log to stdout with
RunAsDaemon set.
Jul 09 15:15:42.677 [warn] Failed to parse/validate config: Failed to
validate Log options. See logs for details.
Jul 09 15:15:42.677 [err] tor_init(): Reading config failed--see
warnings above. For usage, try -h.

I tried running:

# tor

   ..which seemed to work.. But why won't it run using /etc/rc.d/tor ? I
tried setting "-f <path to torrc>" in the rc.d/tor file, but that didn't

Anyone know what I'm doing wrong?

Kind Regards,
Jan Danielsson
Te audire non possum. Musa sapientum fixa est in aure.

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

Version: GnuPG v1.4.4 (MingW32)