Subject: Re: cannot build graphics/xpm
To: None <>
From: George Georgalis <>
List: pkgsrc-users
Date: 04/22/2006 17:39:34
On Sat, Apr 22, 2006 at 02:25:16PM -0700, Jeremy C. Reed wrote:
>On Sat, 22 Apr 2006, George Georgalis wrote:
>>  root@run:/usr/pkgsrc/graphics/xpm # cd /usr/pkgsrc/graphics/xpm && make 
>> CLEANDEPENDS=YES X11_TYPE=xorg clean install /usr/pkgsrc/graphics/xpm
>> ===> Configuring for xpm-3.4knb6
>> cd: can't cd to /usr/pkgsrc/graphics/xpm/work/xpm-3.4k
>> cd: can't cd to /usr/pkgsrc/graphics/xpm/work/xpm-3.4k
>The do-configure target should fail if the cd ${WRKSRC} fails.

sounds good.

>(This should be checked in other places too.)
>> mv -f Makefile Makefile.bak
>Ouch. The change directory failed.
>That actually moved the pkgsrc/graphics/xpm/Makefile!

yeah, I noticed that...

>For now, don't use the CLEANDEPENDS and the install in the same target.

after a clean cvs up I get the same results...

 root@run:/usr/pkgsrc/graphics/xpm # make X11_TYPE=xorg install                                                
===> Checking for vulnerabilities in xpm-3.4knb6
=> Checksum SHA1 OK for xpm-3.4k.tar.gz.
=> Checksum RMD160 OK for xpm-3.4k.tar.gz.
===> Extracting for xpm-3.4knb6
===> Required installed package xorg-libs>=6.9.0nb2: xorg-libs-6.9.0nb2 found
===> Required installed package fontconfig>=2.3.2nb2: fontconfig-2.3.2nb2 found
===> Required installed package freetype2>=2.1.10nb1: freetype2-2.1.10nb2 found
===> Required installed package expat>=2.0.0nb1: expat-2.0.0nb1 found
===> Required installed package xpkgwedge>=1.15: xpkgwedge-1.15 found
===> Required installed package xorg-imake>=6.8: xorg-imake-6.9.0nb1 found
===> Patching for xpm-3.4knb6
===> Applying pkgsrc patches for xpm-3.4knb6
===> Overriding tools for xpm-3.4knb6
===> Creating toolchain wrappers for xpm-3.4knb6
===> Configuring for xpm-3.4knb6
imake -DUseInstalled -I/usr/pkg/lib/X11/config -I/usr/X11R6/lib/X11/config
Imakefile.c:16: Imake.tmpl: No such file or directory
/usr/pkgsrc/graphics/xpm/work/.tools/bin/imake: Exit code 1.
*** Error code 1

make: stopped in /usr/pkgsrc/graphics/xpm
===> There was an error during the ``configure'' phase.
===> Please investigate the following for more information:
===>      * log of the build
===>      * /usr/pkgsrc/graphics/xpm/work/.work.log
*** Error code 1

make: stopped in /usr/pkgsrc/graphics/xpm

The log looks the same.  I was trying...

 # cd  /usr/pkgsrc/print/teTeX  && make X11_TYPE=xorg install

Not sure how to fix...

// George

George Georgalis, systems architect, administrator <IXOYE>< cell:646-331-2027