pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: pkgsrc/inputmethod

On Tue, 24 Apr 2012 11:20:36 +0900, David Holland 
<> wrote:

On Tue, Apr 24, 2012 at 10:08:45AM +0900, OBATA Akio wrote:
 >>> Log Message:
 >>> Update input-pad to 1.0.1.
 >> py{25,26}-input-pad fail because they're trying to depend on both
 >> py{25,26}-gtk2 and py27-gtk2.
 >> I don't immediately see why...
 > 1. remove ibus dependency from eekboard, it's easiest way.
 > 2. remove py-input-pad from pkgsrc, it's easer way.
 > 3. merge py-input-pad to input-pad package, it's easy way.
 > 4. split up ibus package into non-python part and python part, it's
 >    hard way.
 > 5. let py-gtk2 packages not to conflict, it's hardest way.

Another option is to do what I did in py-gnome2-desktop.

For py-gnome2-desktop, it exactly require gnome2-desktop built with same python 
For py-input-pad, it is using py-gtk2 directly and depending on ibus indirectly.
Then ibus python part depend on py-gtk2, but it is not relevant to py-input-pad.

OBATA Akio /

Home | Main Index | Thread Index | Old Index