pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: pkgsrc/devel/atk

On Sat, 16 Jul 2011 22:41:05 +0900, Matthias Scheler 
<> wrote:


On Fri, Jul 15, 2011 at 08:07:04AM +0000, Ryo ONODERA wrote:
Module Name:    pkgsrc
Committed By:   ryoon
Date:           Fri Jul 15 08:07:03 UTC 2011

Modified Files:
        pkgsrc/devel/atk: Makefile distinfo

Log Message:
Update to 2.0.1

This update is not backwards compatible, at least not under Mac OS X:

dyld: Library not loaded: /usr/pkg/lib/libatk-1.0.0.dylib
  Referenced from: /usr/pkg/bin/xchat
  Reason: Incompatible library version: xchat requires version 3210.0.0 or 
later, but libatk-1.0.0.dylib provides version 11.0.0
zsh: trace trap  xchat

Please update "BUILDLINK_ABI_DEPENDS.atk" and perform a recursive
package revision bump of all packages depending on "atk".

I feel that it is upstream issue.

shlib name should be bumped to libatk-2.0.0.dylib, or provided version should 
be 20011.0.0.

OBATA Akio /

Home | Main Index | Thread Index | Old Index