pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: pkgsrc/textproc/docbook-xsl

On 19/04/2011 09:09, Thomas Klausner wrote:
On Tue, Apr 19, 2011 at 06:32:48AM +0000, Roy Marples wrote:
Module Name:    pkgsrc
Committed By:   roy
Date:           Tue Apr 19 06:32:48 UTC 2011

Modified Files:
        pkgsrc/textproc/docbook-xsl: Makefile PLIST

Log Message:
epub XSLMOD requires ruby, so we no longer install it.

Just depend on ruby.

I have no preference either way - I just want developer lazyness addressed when scripts are installed with broken or non existant interpreters through env(1) abuse.

I'll depend on ruby as I cba to create a new package at this time.
From hence forth I'll just add dependencies to other packages like this I find.

If you find that's too much of a dependency, you can either still
leave it in (and let people manually install ruby if they need it) or
add a separate package installing it with a ruby dependency.

I don't think just removing it is a nice solution.

Well my thought was as it doesn't work anyway (no ruby version is pulled in on my install) then I may was well punt it.



Home | Main Index | Thread Index | Old Index