pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

CVS commit: pkgsrc/www/webkit-gtk

Module Name:    pkgsrc
Committed By:   snj
Date:           Wed May 20 03:28:48 UTC 2009

Modified Files:
        pkgsrc/www/webkit-gtk: Makefile PLIST distinfo

Log Message:
Update to 1.1.7.

- Do not handle KeyEvents with Ctrl or Alt modifiers that we
  otherwise know nothing about. Otherwise shortcuts defined in the
  WebView will never be executed.
- Add information about the SVG index bounds check committed in r43590.
- For paste from middle button (button==2) we want to use
  the GDK_PRIMARY_SELECTION. Implement the new getCurrentTarget
  method in PasteboardHelperGtk by asking the WebView which
  clipboard to use.
- Add glib-2.0 to the list of required package.
- (test_webkit_web_frame_create_destroy): Declare webView as a GtkWidget*
  to fix pointer type incompatibility warnings.
- Make the scan program call g_thread_init(NULL) in addition to
  g_type_init(), so that it actually works.
- Unify scrolling code via adjustments and keys. Use the WebCore
  defined constants, since that's what people are most used to at
  this point.
- Add missing call to notifyStatus in the committed case and a
  missing property notify.
- When a download is requested by an ongoing request, use the already
  provided response to set the suggested filename for the WebKitDownload
  object, if available.
- Remove bogus extern "C" from some source files.
- Misc fixes to InspectorClientGtk: use g_filename_to_uri to
  get the URI and use web_view_load_uri instead of the deprecated
  web_view_open method for loading the URI.
- Add #if ENABLE(DATABASE) guards around database code so toggling
  ENABLE_DATABASE off does not break builds.
- Implement load-status and progress properties on the view, as well as
  load-status on the frame. This supersedes the different load signals
  load-progress-changed, load-committed, load-done, load-started and
  load-finished which are not only misnamed but broken by design.
- Fix memory leaks.
- Use strlen instead of g_utf8_strlen when calculating the size of
  the data that is being given to webkit_web_frame_load_string to be
  loaded, so that we don't miss any of the content.
- Fix mis-applied patch.
- Add a FrameLoaderClient callback for ResourceRetrievedByXMLHttpRequest.
- Provide a mechanism to create a quirks delegate for HTMLParser
- Add MessageSource and MessageLevel parameters to

To generate a diff of this commit:
cvs rdiff -u -r1.9 -r1.10 pkgsrc/www/webkit-gtk/Makefile
cvs rdiff -u -r1.5 -r1.6 pkgsrc/www/webkit-gtk/PLIST
cvs rdiff -u -r1.8 -r1.9 pkgsrc/www/webkit-gtk/distinfo

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.

Home | Main Index | Thread Index | Old Index