pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

CVS commit: pkgsrc/devel/p5-Exception-Class

Module Name:    pkgsrc
Committed By:   sno
Date:           Wed May  6 06:41:16 UTC 2009

Modified Files:
        pkgsrc/devel/p5-Exception-Class: Makefile distinfo

Log Message:
PkgSrc changes:
  - Updating package for p5 module Exception::Class from 1.26 to 1.27
  - Adjusting dependencies

Upstream changes:
1.27 May 4, 2009

* The error message for an exception no longer defaults to $!. This
  was a bad idea, and has bitten some people. Addresses RT #43600.

* I'm now only supporting Perl 5.8.1+. This module broke on 5.6.2 (and
  5.8.0) at some point and I don't really care enough to fix
  it. Non-intrusive patches to make it work on 5.8.0 or less (again)
  will be accepted.

To generate a diff of this commit:
cvs rdiff -u -r1.18 -r1.19 pkgsrc/devel/p5-Exception-Class/Makefile
cvs rdiff -u -r1.7 -r1.8 pkgsrc/devel/p5-Exception-Class/distinfo

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.

Home | Main Index | Thread Index | Old Index