pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

CVS commit: pkgsrc/devel/p5-Class-MOP

Module Name:    pkgsrc
Committed By:   seb
Date:           Mon Oct 27 00:03:14 UTC 2008

Modified Files:
        pkgsrc/devel/p5-Class-MOP: Makefile distinfo

Log Message:
Update from version 0.67 to version 0.68.

0.68 Fri October 25, 2008
    * Class::MOP
      - Make load_class require by file name instead of module name.
        This stops confusing error messages when loading '__PACKAGE__'.
        (Florian Ragwitz)
      - Add load_one_class_of function to enable you to load one of a
        list of classes, rather than having to call load_class multiple
        times in an eval. (t0m)

To generate a diff of this commit:
cvs rdiff -r1.7 -r1.8 pkgsrc/devel/p5-Class-MOP/Makefile
cvs rdiff -r1.5 -r1.6 pkgsrc/devel/p5-Class-MOP/distinfo

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.

Home | Main Index | Thread Index | Old Index