pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: pkgsrc/www/trac

On Mon, 15 Sep 2008, Manuel Bouyer wrote:

On Mon, Sep 15, 2008 at 11:50:06AM +0000, Joerg Sonnenberger wrote:

Module Name:    pkgsrc
Committed By:   joerg
Date:           Mon Sep 15 11:50:06 UTC 2008

Modified Files:
        pkgsrc/www/trac: Makefile

Log Message:
The sqlite3 requires py-sqlite3, which is currently Python 2.5 only.

As PYTHON_VERSION_DEFAULT is still 2.4, wouldn't it be  better to default to
sqlite2 instead of sqlite3 ?

        I've unborked the original breakage introduced by my 0.11.1
        upgrade. py-sqlite2 is actually sqlite3 for python < 2.5,
        py-sqlite3 is sqlite3 for python 2.5, py-sqlite is sqlite2 (and
        wasn't used in trac). I can't wait for sqlite4 and python 2.6
        to start to complicate things.

                David/absolute       -- No hype required --

Home | Main Index | Thread Index | Old Index