pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

CVS commit: pkgsrc/misc/rubygems

Module Name:    pkgsrc
Committed By:   jlam
Date:           Tue Mar 11 22:11:33 UTC 2008

Modified Files:

Log Message:
+ We need rubygems>=1.0.1nb1 (which has the OpenSuSE buildroot patch)
  for building and installing the gems, but we can use older rubygems
  at run-time.

+ Move GEMFILE definition ahead of EXTRACT_SUFX just as a style issue.
  This looks more like a normal package Makefile layout.

+ Rename GEMS_BASEDIR to GEM_HOME, which is the actual rubygems variable
  name for that directory.

+ Rename some variables to be more in line with other ruby variable

        GEM_LIB_DIR     => GEM_LIBDIR
        GEM_DOC_DIR     => GEM_DOCDIR

+ Set RUBYGEM_PKGPREFIX to ${RUBY_PKGPREFIX}-gem for now.  We know
  that at least we don't want ruby packages to prefix with "rubygems".

+ Just use EVAL_PREFIX instead of directly using

To generate a diff of this commit:
cvs rdiff -r1.1 -r1.2 pkgsrc/misc/rubygems/

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.

Home | Main Index | Thread Index | Old Index