Subject: Re: CVS commit: pkgsrc/www/htdig-devel
To: None <>
From: Martijn van Buul <>
List: pkgsrc-changes
Date: 12/18/2005 13:57:21
Mark Davies wrote:
> Log Message:
> Import of latest htdig beta release (from 18 months ago) as htdig-devel.
> No conflicts created by this import

well, that remains to be seen ;)

Would you consider raising the required versionnumber for htdig as required
by kdevelop-base, or remove that dependency altogether? Right now, kdebase
requires htdig>=3.2.0, while kdevelop requires htdig>=3.1.0, yet at the same
time requires kdebase. 

I know that this is technically correct, and that there *is* a sequence of
package installation which would just work out right, but it is a bit 
fishy. In fact, trying to install kdevelop on a bare system wouldn't even
work, as the dependency on htdig is resolved before the dependency on 
kdebase is. So htdig-3.1.6 will be installed *before* htdig-3.2.0, causing
a conflict. This can cause also issues for build managers[1]. 

IMHO, the dependency on htdig isn't required for kdevelop-base, as it is
already inherited from kdebase. 

Kind regards,


[1] Actually, it breaks pkgmanager, but I understand that this isn't the
    biggest concern right now.
    Martijn van Buul - -
	 Geek code: G--  - Visit OuterSpace: 3333
 The most exciting phrase to hear in science, the one that heralds new
discoveries, is not 'Eureka!' (I found it!) but 'That's funny ...' Isaac Asimov