Subject: CVS commit: pkgsrc/pkgtools/pkglint
To: None <>
From: Roland Illig <>
List: pkgsrc-changes
Date: 11/24/2005 08:05:01
Module Name:	pkgsrc
Committed By:	rillig
Date:		Thu Nov 24 08:05:01 UTC 2005

Modified Files:
	pkgsrc/pkgtools/pkglint: Makefile

Log Message:
Updated pkglint to 4.45.3.

- Added detection of redirection operators and comments to the
  regex_shellword constant.
- Changed the naming conventions for list data types. Now List simply
  means a list. List+ means a list that should only be modified using
  "+=", not "=". List! means an internal list. And List!+ is the
  combination of both.

  The distinction is necessary because of the introduction of
  redirection operators in the regex_shellword. When checking the data
  type of list elements, the lists are split up into shell words instead
  of simply using split(). This leads to much better results.
- When splitting a variable value or shell command into words, anchor the
  regular expression at the beginning of the string.

To generate a diff of this commit:
cvs rdiff -r1.307 -r1.308 pkgsrc/pkgtools/pkglint/Makefile
cvs rdiff -r1.37 -r1.38 pkgsrc/pkgtools/pkglint/files/
cvs rdiff -r1.380 -r1.381 pkgsrc/pkgtools/pkglint/files/

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.