Subject: Re: CVS commit: pkgsrc/mk
To: Roland Illig <>
From: Alistair Crooks <>
List: pkgsrc-changes
Date: 09/28/2005 11:03:00
On Wed, Sep 28, 2005 at 08:24:53AM +0000, Roland Illig wrote:
> Module Name:	pkgsrc
> Committed By:	rillig
> Date:		Wed Sep 28 08:24:53 UTC 2005
> Modified Files:
> 	pkgsrc/mk:
> Log Message:
> Added a variable LICENSE_FILE that may be set to point to the license
> file of the package. It does _not_ replace the LICENSE variable. The
> variable is currently only used in the show-license target. It is
> intended that LICENSE_FILE is used for licenses that only apply to a
> single package or a package group, so that the number of licenses in the
> licenses/ directory is kept small.

I'm not clear why yet another Makefile definition was added
to the mix here, given that pkgsrc controls the name of the
licen[cs]e file here in the licenses/ directory and the pkgsrc
Makefile for the package, and that we have enough trouble with
alternate spellings already without adding yet another one for
almost no gain, AFAICT.