Subject: Re: CVS commit: pkgsrc/databases/libgnomedb
To: Matthias Drochner <>
From: Krister Walfridsson <>
List: pkgsrc-changes
Date: 03/05/2005 20:14:01
On Thu, 3 Mar 2005, Matthias Drochner wrote:

> Module Name:	pkgsrc
> Committed By:	drochner
> Date:		Thu Mar  3 16:39:28 UTC 2005
> Modified Files:
> 	pkgsrc/databases/libgnomedb: Makefile
> Log Message:
> require gcc-3.3 (I don't understand the problem with 2.95, but it helps)
> should fix problem seen on 1.6 bulk build

Please do not require gcc 3.x unless you know that it cannot easily
be fixed to work with gcc 2.95.  This is especially important for
libraries cointaining C++, since compiling them with gcc3 requires
you to use gcc3 for all applications that use them.

PS. The failure in this particular package is one declaration
that use the C99 feature that you can declare a variable after
a statement.  I'll commit a fix soon, and remove the GCC_REQD.