pkgsrc-Bulk archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkgsrc NetBSD 8.99.2/x86_64 2017-09-08 19:21

On Sat, Sep 09, 2017 at 07:29:24PM +0200, Joerg Sonnenberger wrote:
 > Build failures
 > Package                               Breaks Maintainer
 > -------------------------------------------------------------------------
 > archivers/py-zstandard             

Looks like version skew against its parent library.

 > audio/libgroove                    

Two failures, one on an 8-bit vs. 16-bit buffer (!?) at the top of the
log and the other a broken perl script at the bottom.

 > cad/ghdl                           

C compiler cannot create executables; Joerg, can you fetch the

 > cad/librecad                       

Undefined references to its own symbols (which are C++ destructors)

 > cad/openscad                       

#error For Clang to work, CGAL must be >= 4.0.2

 > cad/tnt-mmtl                       

Coredump generating tex docs (is this an instance of that poppler issue?)

 > chat/ircservices                   

use of unknown builtin '__builtin_return'
use of unknown builtin '__builtin_apply'
use of unknown builtin '__builtin_apply_args'

Should this just get marked BROKEN_ON clang?

 > chat/matterircd                    

Distfile won't extract.

 > chat/tkicb                         

Distfile won't fetch.

 > comms/asterisk                     
 > comms/asterisk13                   
 > comms/asterisk14                           1

configure: error: BlocksRuntime is required for clang, please install
(all three of these)

 > comms/asterisk18                   

Symbol conflict with libc on hmac().

 > converters/wkhtmltopdf             

Basic XLib functionality test failed!
You might need to modify the include and library search paths by
editing QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in

 > cross/bfd-crunchide                
 > cross/bfd-mdsetimage               

Needs -fPIC since it's trying to link as a PIE.
(both of these)

 > cross/h8300-elf-gcc                

clang: error: unsupported option '-print-multi-os-directory'

There was a second failure (missing header for select) that should be
fixed now.

 > cross/nios2-gcc3                   

Bad PLIST, probably fixed, or at least will be different next go.

 > databases/clisp-gdbm               

This should be fixed, fault was in gdbm.

 > databases/couchdb                  

Bad erlang version:
ERROR: OTP release 20 does not match required regex R16B03|R16B03-1|17|18|19

 > databases/mariadb55-client                 1

Inadequate REPLACE_PERL; fixed.

 > databases/mongo-c-driver                   1

Syntax error in configure script; fixed.

 > databases/mysql-workbench          

Missing sys/stat.h; fixed.

 > databases/mysql57-server                   1


 > databases/openldap-smbk5pwd        

krb5 issues.

 > databases/postgresql-pgroonga      

groonga.h not found.

 > databases/ruby-odbc                        2
 >     ruby24-odbc-0.99997                    2

invalid operands to binary expression ('char *' and 'char *')
(repeated many times on the same line, go figure)

 > devel/acme                         

Distfile didn't uncompress (same failure last go, but it works for me...?)

 > devel/adacurses                    

C compiler cannot create executables. Or, more likely, something about
Ada and setting the compiler to clang...

 > devel/clisp-syscalls               

Signal 11 during build. Has this package ever worked? It was a
long-term chronic failure back in like 2012 when I was tracking these

 > devel/coconut                      

objc/Protocol.h file not found

 > devel/cqual                        

Does not work with the default emacs version. (This too has been
broken since like 2012...)

 > devel/emacs-ilisp                          3

Elisp issues.

 > devel/florist                      

C compiler cannot create executables. Or, more likely, something about
Ada and setting the compiler to clang...

 > devel/frama-c                      

The included jemalloc fails to configure, with "C compiler cannot
create executables". Joerg, please send me the config.log from that...

note though that ultimately it won't build anyway without non-default
option settings in ocaml-graphics..

 > devel/gnustep-objc-lf2                     2

use of unknown builtin '__builtin_apply' etc.
Should this one be masked too? It's been broken on clang since

 > devel/go-cli                               2
 > devel/go-pflag                             3

Check-interpreter failure. (both of these)

 > devel/libdwarf                     

Seems to be including both libelf and base's elf headers and falling
on its face as a result.

 > devel/libjit                       

Clang seems to be allergic to the way it's attaching a local variable
directly to a register.

 > devel/magit                        

Elisp issues.

 > devel/objfw                        

Crashes clang.

 > devel/ocaml-compiler-libs                 10
 > devel/ocaml-migrate-parsetree             19
 > devel/ocaml-ppx_derivers                   7
 > devel/ocaml-ppx_traverse_builtins          9

opam-installer: not found
Hopefully all of these will get further the next time.

 > devel/p5-Data-Alias                        2
 > devel/p5-Devel-BeginLift                   1

The C clue for these two doesn't build, in the same way for both.

 > devel/phabricator                  

Depends on multiple php versions at once.

 > devel/prcs                         

'ext/stdio_filebuf.h' file not found
This one has also been broken ~forever, hasn't it?

 > devel/ptlib                                2

error: use of undeclared identifier 'RTF_LLINFO'
(fallout from a base change AIUI)

 > devel/py-clickclick                

Could not find suitable distribution for Requirement.parse('pyflakes<1.6.0,>=1.5.0')

 > devel/py-pylint                    
 >     py36-pylint-1.7.2              
 >     py34-pylint-1.7.2              
 >     py35-pylint-1.7.2              

Could not find suitable distribution for Requirement.parse('pytest-runner')

 > devel/py-radon                             2
 >     py27-radon-2.0.3                       2

"" doesn't work; should this be marked incompatible with py27?

 > devel/py-tox                              10
 >     py35-tox-2.8.1                         3
 >     py36-tox-2.8.1                         4
 >     py34-tox-2.8.1                         3

Could not find suitable distribution for Requirement.parse('setuptools_scm')

 > devel/radare2-valabind                     5

The name `get_ctype' does not exist in the context of `Vala.Field'

 > devel/rt-mysql                     
 > devel/rt-pgsql                     

Can't locate Specio/ in @INC (aka perl update fallout)

 > devel/ruby-redmine                        13
 >     ruby24-redmine-3.3.2nb2               13

error: use of undeclared identifier 'rb_cFixnum'
error: use of undeclared identifier 'rb_cBignum'

 > devel/sdcc3                        

gp_calloc() -- Could not allocate memory for 65536 objects of 64 bytes
each. {gpmemory.c.LINE-308, b_memory_put()}

I remember looking into this and figuring it out, but not the
conclusion about what to do about it. That would have been at least a
couple years ago I think...

 > devel/sfio                         

Was trying to use varargs, should be fixed.

 > devel/sfslite                      

C++ issues, should be fixed or at least improved.

 > devel/snappy-java10                        2

Unresolveable build extension: Plugin
  org.apache.maven.wagon:wagon-ssh-external:1.0-beta-7 or one of its
  dependencies could not be resolved: Cannot access central
  ( in offline mode and the
  artifact org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-7 has
  not been downloaded from it before.

 > devel/verifast                     

Misuse of the implementation namespace; should be fixed.

 > devel/xulrunner24                  

C++ issues.

 > devel/xulrunner45                          1

gstreamer-related stuff missing from PLIST, but gstreamer is
explicitly disabled... maybe bad options logic?

 > editors/emacs22                            3
 > editors/emacs22-nox11              
 > editors/emacs23                    
 > editors/emacs23-nox11              

Wrong type argument: listp, 17523466184580
Wrong type argument: listp, 17523465255384
Wrong type argument: listp, 35046930063376
Wrong type argument: listp, 35046929354200

while dumping.

 > editors/pluma                              1

Check-interpreter failure; should be fixed.

 > emulators/mame                     

Missing clang build rules; should be fixed.

 > emulators/stella                   

Botched clang configure probe; should be fixed.

 > emulators/xm7                      

Distfile won't download.

 > filesystems/fuse-ntfs-3g           

fuse api version skew (apparently)

 > filesystems/openafs-devel          

Needs afs sysnames for netbsd 8 & 9, plus the associated configury.

 > filesystems/ori                    


 > games/bastet                       


 > games/craft                        

This thing's weird preprocessor has never worked with clang. I might
fix it sometime, maybe.

 > games/gnome-sudoku                 

msgfmt: unknown option -- desktop

 > games/gnuchess-book                
 > games/gnuchess-book-medium         

SIGABRT (both of these)

 > geography/merkaartor               

error: no member named 'Open' in 'OGRSFDriverRegistrar'
(also see osg)

 > geography/opencpn                  

C++ issues; seems to be getting confused by having both <wchar.h> and

 > geography/proj-swig                

Partial update. Should be fixed.

 > geography/qlandkartem              

C++ issues; should be fixed or at least improved.

 > geography/vis5d+                   

Fortran syntax errors. IIRC this means it's using the wrong fortran
compiler but I don't remember the details.

 > graphics/aqsis                     


 > graphics/asymptote                         2

Signal 9 when running itself to build its docs

 > graphics/inkscape                  

C++ issues

 > graphics/ivtools                   

'ext/stdio_filebuf.h' file not found

 > graphics/kipi-plugins              

PLIST divergence, not clear why

 > graphics/libkface                          1

cmake can't find opencv

 > graphics/nvidia-texture-tools      

Didn't build with -fPIC

 > graphics/osg                               2

no member named 'Open' in 'OGRSFDriverRegistrar'
(also see merkaartor)

 > graphics/py-pygal                  
 >     py36-pygal-2.4.0               
 >     py35-pygal-2.4.0               
 >     py34-pygal-2.4.0               

Could not find suitable distribution for Requirement.parse('pytest-runner')
Hopefully fixed.

 > graphics/scidavis                  

C++ issues: no viable conversion from 'bool' to 'Qt::ItemFlags' (aka

 > graphics/shotwell                  

overriding method `Gee.HashSet.foreach' is incompatible with base
method `Gee.AbstractCollection.foreach': incompatible type of
parameter 1.

 > inputmethod/ibus-qt                

Apparently wants graphviz.

 > inputmethod/ibus-table-chinese     

Variety of cmake errors, including a complaint that cmake isn't
installed. (!)

 > lang/abcl                          

java.lang.OutOfMemoryError: Compressed class space

 > lang/boomerang                     

ocaml issues

 > lang/cint                          

bogus patch, has been removed

 > lang/coreclr                       

Misuse of the implementation namespace.

 > lang/gcc3-c                                4
 > lang/gcc34                         
 > lang/gcc44                         

unknown field `ptm_ceiling' specified in initializer
(all three of these)

 > lang/gforth                        

Crashes clang.

 > lang/gprolog                       

clang: error: unknown argument: '-ffixed-r12'
clang: error: unknown argument: '-ffixed-r13'
clang: error: unknown argument: '-ffixed-r14'
clang: error: unknown argument: '-ffixed-r15'

 > lang/guile22                       

Appears to be extracting info from system headers and doing it wrong.

 > lang/mercury                       

Huge plist divergence, probably consequence of some other failure.

 > lang/nhc98                         

Needs -fheinous-gnu-extensions, or asm cleanup.

Also throwns shell syntax errors I can't reproduce.

 > lang/onyx                          

Fails build with no diagnostic messages.

 > lang/oo2c                          

Uses nested functions. Should probably be marked BROKEN_ON clang.

 > lang/oracle-jre8                           1

Distfile won't fetch.

 > lang/pfe                           

register '%r15' unsuitable for global register variables on this target

 > lang/polyml                        

Insufficient memory to allocate the heap
(also crashes during build for me)

 > lang/py-cxfreeze                   
 >     py27-cxfreeze-5.0.1            

Needs to be but isn't linking against pthreads.

 > lang/py-js2py                      
 >     py27-js2py-0.50                

PLIST divergence (extra files), not immediately clear why.

 > lang/racket-textual                

Signal 11 during build.

 > lang/rust                          

Shared object "" not found
(during configure)

 > lang/sbcl                          

genesis/Makefile.features: No such file or directory

 > lang/smalltalk                     

prims.def:3385:15: warning: invalid conversion specifier 'O' [-Wformat-invalid-specifier]
    printf ("%O error: %#O\n\n", oop1, oop2);

 > lang/smlnj                                   richards+netbsd%CS.Princeton.EDU@localhost
 > lang/smlnj11072                              richards+netbsd%CS.Princeton.EDU@localhost

Runs out of memory during build.
(and for me, mostly dumps core during build)

 > lang/spl                           

Uses nested functions.

 > lang/swi-prolog-jpl                

Failed to build with -PIC.

 > mail/gnus                          

Elisp issues.

 > mail/milter-regex                  

Failed to build with -PIC.

 > mail/p5-Mail-ClamAV                

ERROR: pcre>=3.4nb1 is not installed; can't buildlink files.

 > mail/py-aiosmtpd                   
 >     py34-aiosmtpd-1.0a5            

python syntax errors (probably incompatible with py34?)

 > mail/seamonkey-enigmail            

Unclear PLIST divergence.

 > mail/smtp-vilter                   

Failed to build with -PIC.

 > mail/thunderbird24                 

C++ issues

 > mail/thunderbird38                 

Perl regexp syntax issue?

 > mail/wl                            

Extra files installed (should be fixed)

 > math/R-gstat                       

cannot find -lf95

 > math/R-nloptr                      

Undefined PLT symbol "nlopt_set_maxtime" (symnum = 4)

 > math/pari                                  2

Can't locate PARI/ in @INC (aka perl update fallout)

 > mbone/rat                          

No makefile for NetBSD 8

 > misc/calibre1                      

Python issues: cannot import name viewkeys

 > misc/hanzim                        

Needs an X server to go. (known issue)

 > misc/kdepim4                               2

No rule to make target 'kjots/org.kde.KJotsWidget.xml', needed by

 > misc/libreoffice                           1

libjpeg linkage problems

 > misc/molden                        

ld: cannot find -lssp_nonshared
ld: cannot find -lssp

 > misc/ocaml-topkg                          24

ocaml issues
(inconsistent build)

 > misc/root                          

C++ issues

 > misc/rump                                  1

unknown type name 'register_t'

 > misc/softmaker-office-demo         

Distfile won't fetch.

 > misc/taskjuggler                   

Fails self-tests.

 > misc/tmate                         

"curses not found", hopefully fixed.

 > misc/window                        

error: implicit conversion from 'int' to 'char' changes value from 136
to -120

(should be fixed)

 > multimedia/dvb-apps                

Can't locate in @INC (aka perl update fallout)

 > multimedia/fuppes                  

Confused about language modes: invalid argument '-std=gnu89' not
allowed with 'C++'

 > multimedia/handbrake               

Wants -fheinous-gnu-extensions (should be fixed)

 > multimedia/hwdecode-demos          


 > multimedia/kdemultimedia3                  4

plist divergence without clear reasons

 > multimedia/libva-driver-vdpau      

C issues, probably API version skew.

 > multimedia/p5-xmltv                

one file not installed, not obvious up front why

 > multimedia/vlc                             3

C++ issues: reference to 'atomic_uint_least32_t' is ambiguous

 > net/bird                           
 > net/bird6                          

use of undeclared identifier 'RTF_LLINFO'

 > net/entropy                        

Bad inline assembler.

 > net/ettercap                       

use of undeclared identifier 'RTF_LLINFO'

 > net/freeradius                            13

libevent issues(?)

I think Joerg fixed this today.

 > net/gated                          

use of undeclared identifier 'RTM_RESOLVE'

 > net/gtk-gnutella                   

sha1sum: not found

 > net/guacamole-server               

implicit declaration of function 'pthread_mutexattr_setpshared' is
invalid in C99

 > net/iana-etc                       

ERROR: This package is known to stall the bulk build on these
platforms: *-*-*.

(shouldn't this result in skipping rather than failing it?)

 > net/kismet                         

configure: WARNING: *** Missing Magick-config (or it is not in the
path).  gpsmap will not be built. ***

(with ensuing plist divergence)

 > net/libbind                        

conflicting types for 'sethostent_r'

 > net/libtorrent                             1

tr1/functional' file not found

 > net/mrt                            

use of undeclared identifier 'RTF_CLONING'

 > net/nagios-plugins                         7

Generic C build issues

 > net/pim6dd                         
 > net/pim6sd                         

taking address of packed member 'mld_addr' of class or structure
'mld_hdr' may result in an unaligned pointer value

 > net/ruby-net-telnet                
 >     ruby24-net-telnet-0.1.1        
 >     ruby23-net-telnet-0.1.1        

Conflicts with base ruby.

 > net/sharity-light                  

use of undeclared identifier 'NFS_PROGRAM'

 > net/userppp                                1

use of undeclared identifier 'RTF_LLINFO'

 > net/vnc                            

Imake issues.

 > net/xipdump                        

Problems linking with libpcap.

 > news/nget                          

C++ issues: reference to 'hash' is ambiguous

 > news/pan                           

C++ issues

 > parallel/sge                       

Generic C build issues, apparently vaddr_t.

 > parallel/slurm                     

USes nested functions.

 > pkgtools/pkg                       

Failed to build with -fPIC.

 > print/gtklp                        

Generic C build errors.

 > print/pdf2djvu                     

C++ issues.

 > print/tcl-pdflib                   

Can't link to itself successfully.

David A. Holland

Home | Main Index | Thread Index | Old Index