Subject: Re: pkgsrc NetBSD 2.0_RC5/i386 bulk build results 2004-12-06
To: Krister Walfridsson <>
From: Thomas Klausner <>
List: pkgsrc-bulk
Date: 12/07/2004 16:31:51
On Tue, Dec 07, 2004 at 03:31:45PM +0100, Thomas Klausner wrote:
> 151a152
> > security/tcp_wrappers    
> cd /tmp/bulktmp/security/tcp_wrappers/work/tcp_wrappers_7.6-ipv6.1; libtool install -c -o root -g wheel -m 555 /usr/pkg/lib
> *** Warning: inferring the mode of operation is deprecated.
> *** Future versions of Libtool will require -mode=MODE be specified.
> libtool: install: `' is not a valid libtool archive
> Try `libtool --help --mode=install' for more information.


> 161a162,163
> > wm/sawfish-replibs         2
> checking for correct rep-gtk version... no
> configure: error: You need rep-gtk version 0.14+
> *** Error code 1

The configure problem is, according to config.log:
configure:2563: checking for correct rep-gtk version
rep: received fatal signal: Abort trap
rep: Error detected by libpthread: Invalid condition variable.
Detected by file "/archive/cvs/src/lib/libpthread/pthread_cond.c", line 283, function "pthread_cond_signal".
See pthread(3) for information.

The configure test looks like this:
echo $ac_n "checking for correct rep-gtk version""... $ac_c" 1>&6
echo "configure:2563: checking for correct rep-gtk version" >&5
cat >conftest <<EOF
(condition-case nil
      (require 'gui.gtk.gtk)
      (throw 'quit 0))
    (throw 'quit 1)))
if REP_GTK_DONT_INITIALIZE=1 rep ./conftest 2>&5; then
  echo "$ac_t""yes" 1>&6
  echo "$ac_t""no" 1>&6
  { echo "configure: error: You need rep-gtk version ${rep_gtk_version}+" 1>&2; 
exit 1; }
rm -f conftest

Does rep need linking against libpthread?