Subject: Re: all java packages "broken"?
To: Eric Haszlakiewicz <>
From: Thomas Klausner <>
List: pkgsrc-bulk
Date: 11/26/2004 12:55:56
On Wed, Nov 24, 2004 at 03:38:48PM -0600, Eric Haszlakiewicz wrote:
> 	I took a look at the packages that had my name on them (jakarta-tomcat).
> They are marked broken because they use java and there is no JVM installed.

I don't see this -- where exactly did you notice that?

the error reported is:
	ls: /usr/pkg/tomcat4/webapps/to: No such file or directory
which points to a PLIST problem (file in PLIST that does not get installed).

> 	I didn't see the sun-jdk14 in the listing.  Why not?

If you want to depend on sun-jdk14 by default, you should
set the PKG_JMVS_ACCEPTED variable in the package's Makefile.
See comments at the top of mk/ for details.