pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/49060: misc/libreoffice4 fails to build on NetBSD-6.1.4/amd64

>Number:         49060
>Category:       pkg
>Synopsis:       misc/libreoffice4 fails to build on NetBSD-6.1.4/amd64
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Aug 01 17:30:00 +0000 2014
>Originator:     Greg Oster
>Release:        NetBSD 6.1.4
System: NetBSD mickey 6.1.4 NetBSD 6.1.4 (QUAD) #0: Mon Apr 14 12:36:07 CST 
Architecture: x86_64
Machine: amd64

The build of misc/libreoffice4 fails as follows:

checking expat.h usability... yes
checking expat.h presence... yes
checking for expat.h... yes
checking for XML_ParserCreate in -lexpat... yes
checking whether to enable Embedded OpenType support... no
checking which libebook to use... external
checking for EBOOK... no
configure: error: Package requirements (libe-book-0.0 >= 0.0.2) were not met:

No package 'libe-book-0.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables EBOOK_CFLAGS
and EBOOK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Error running configure at ./ line 209.
*** Error code 25

make: stopped in /usr/pkgsrc/misc/libreoffice4
*** Error code 1

make: stopped in /usr/pkgsrc/misc/libreoffice4
*** Error code 1

make: stopped in /usr/pkgsrc/misc/libreoffice4
** 'cd /usr/pkgsrc/misc/libreoffice4 && /usr/bin/make update CLEANDEPENDS=yes' 

The libe-book package is installed, and is version 0.1.1.


    cd /usr/pkgsrc/misc/libreoffice4
    make install

    please. thanks.


Home | Main Index | Thread Index | Old Index