pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/48975: pkgin un-necessarily complains about conflicting packages

>Number:         48975
>Category:       pkg
>Synopsis:       pkgin un-necessarily complains about conflicting packages
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jul 08 08:15:00 +0000 2014
>Originator:     Havard Eidnes
>Release:        NetBSD 6.1.4
        UNINETT AS
System: NetBSD 6.1.4_PATCH NetBSD 6.1.4_PATCH (GENERIC) #1: 
Sun Jun 29 13:59:55 CEST 2014 i386
Architecture: i386
Machine: i386
        Trying to update the pkg installation on one of my machines
        using "pkgin" gives me this warning:

floke# pkgin fug
calculating dependencies... done.
postgresql93-client-9.3.4 (to be installed) conflicts with installed package 
proceed ? [y/N] 

        This is the same base package name, so why can't just pkgin
        put it on the list of packages which needs to be updated,
        instead of complaining that it conflicts?

        This is with

floke# pkgin -v
pkgin 0.6.4 for NetBSD-6.0 i386 (using SQLite 3.7.10)

       in the pkgin-0.6.4nb3 version.

        Don't exactly know.  I have taken a copy of my /var/db/pkg,
        Sorry, don't know.

Home | Main Index | Thread Index | Old Index