pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/48931: Unable to compile x11/gtk2 on NetBSD 5.2/i386

>Number:         48931
>Category:       pkg
>Synopsis:       Unable to compile x11/gtk2 on NetBSD 5.2/i386
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Jun 20 11:05:00 +0000 2014
>Originator:     David H. Gutteridge
>Release:        NetBSD 5.2 with current pkgsrc
Jun 10 22:26:54 EDT 2014

When trying to build gtk2 (in the process of rebuilding pretty much
everything in pkgsrc from scratch), I'm getting a build failure as
follows below. I'm using native X11, not the "modular" version from
pkgsrc (though I see pkgsrc needs to pull in a whole bunch of newer
X11 packages to build).

===> Installing dependencies for gtk2+-2.24.22nb5
The supported build options for gtk2+ are:

        cups debug x11

The currently selected options are:


You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or the following variable.  Its current value is shown:

        PKG_OPTIONS.gtk2 (not defined)

The following variables will affect the build process of this package,
gtk2+-2.24.22nb5.  Their current value is shown below:


Based on these variables, the following variables have been set:

        * PYPACKAGE = python27

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Tool dependency libtool-base>=2.2.6bnb3: found libtool-base-2.2.6bnb3
=> Tool dependency gmake>=3.81: found gmake-3.81
=> Tool dependency perl>=5.0: found perl-5.20.0nb1
=> Tool dependency pkg-config>=0.25: found pkg-config-0.28
=> Tool dependency xz>=4.999.9betanb1: found xz-5.0.0
=> Build dependency x11-links>=0.91: found x11-links-0.91
=> Build dependency gobject-introspection>=1.34.0: found 
=> Build dependency fixesproto>=3.0.0: found fixesproto-5.0
=> Build dependency xextproto>=7.0.3: found xextproto-7.3.0
=> Build dependency inputproto>=2.3: found inputproto-2.3.1
=> Build dependency xineramaproto>=1.1.1: found xineramaproto-1.2.1
=> Build dependency compositeproto>=0.3.1: found compositeproto-0.4.2
=> Build dependency xcb-proto>=1.4: found xcb-proto-1.10
=> Build dependency damageproto>=1.1.0: found damageproto-1.2.1
=> Build dependency xf86vidmodeproto>=2.3: found xf86vidmodeproto-2.3.1
=> Full dependency py27-expat-[0-9]*: found py27-expat-2.7.7
=> Full dependency shared-mime-info>=1.0nb1: found shared-mime-info-1.3
=> Full dependency atk>=2.6.0: found atk-2.10.0
=> Full dependency glib2>=2.34.0: found glib2-2.38.2nb2
=> Full dependency gdk-pixbuf2>=2.26.5nb2: found gdk-pixbuf2-2.30.3
=> Full dependency libX11>=1.5: NOT found
=> Verifying reinstall for ../../x11/libX11
=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Configuring for libX11-1.6.2nb1


checking for X11... configure: error: Package requirements (xproto >= 7.0.17 
xextproto xtrans xcb >= 1.1.92 kbproto inputproto) were not met:

Requested 'xproto >= 7.0.17' but version of Xproto is 7.0.15

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables X11_CFLAGS
and X11_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error code 1

make: stopped in /home/disciple/pkgsrc/x11/libX11

Installing a newer version of Xproto from pkgsrc doesn't resolve the
issue, presumably because the build is preferring the older native
Try building x11/gtk2.

Home | Main Index | Thread Index | Old Index