pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: PR/48197 CVS commit: pkgsrc/devel/frink

The following reply was made to PR pkg/48197; it has been noted by GNATS.

From: "Kai-Uwe Eckhardt" <>
Subject: Re: PR/48197 CVS commit: pkgsrc/devel/frink
Date: Tue, 11 Feb 2014 22:33:39 +0100 (CET)

 > So, which is preferred version (status of 2.3.1.a2)?
 > I cannot see 2.3.1.a2 version in HOMEPAGE, and frink.tar.gz on FTP
 > server still point to 2.2.2p4.
 Since both of them are several years old and there is no test suite
 to evaluate their quality, we should decide based on the needs of
 potential users and contributors like Edgar. I wrote wip/tcl-frink
 before reading the PR, but it turns out that Edgar's version provides
 a small patch for 2.2.2p4 and bigger changes for 2.3.1a2. His version
 for 2.2.2p4 does not build on NetBSD current, so I suggest to take
 the following steps:
 1) Add patches-2.2.2/patch-aa to devel/frink to get a working version
 of the latest release. Check pbulk results for major platforms.
 devel/frink works on NetBSD current with gcc and clang.
 2) Then update to 2.3.1a2 with Edgar's patches.
 3) Edgar, have you tried to contact the original author ? 

Home | Main Index | Thread Index | Old Index