pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/48532 (x11/xrandr wants libXrandr >= 1.4)

The following reply was made to PR pkg/48532; it has been noted by GNATS.

From: Makoto Fujiwara <>
Subject: Re: pkg/48532 (x11/xrandr wants libXrandr >= 1.4)
Date: Wed, 05 Feb 2014 22:33:43 +0900

 Thank you, obache@, but,
 (1) With pbulk environment, 
   - NetBSD/amd64 6.1.2 (with X11R7)
   - cvs update (to mirror, at least xrandr and libXrandr are updated)
   - All the packages built before are purged.
   - X11_TYPE is not set
 only x11/randr is set in limited_list.
 Following depending packages are built, and fails at last:
 [1/9] Successfully built digest-20121220
 [2/9] Successfully built checkperms-1.11
 [3/9] Successfully built libtool-base-2.4.2nb5
 [4/9] Successfully built osabi-NetBSD-6.1.2
 [5/9] Successfully built readline-6.2nb1
 [6/9] Successfully built pkg-config-0.28
 [7/9] Successfully built x11-links-0.81
 [8/9] Successfully built nickle-2.77
 [9/9] Failed to build    xrandr-1.4.1
 (2) Just to make sure, 
    - packaged x11-links manually NOT using pbulk.
    - copy this x11-links to pbulk /packages/All
     -rw-r--r--  1 makoto  wheel  31856 Feb  5 22:14 
     -rw-r--r--  1 root    wheel  29269 Feb  5 22:12 
    - pbulk again (without purging built above (1)).
 Both fails as before:
 Package xorg-macros was not found in the pkg-config search path.
 Perhaps you should add the directory containing `xorg-macros.pc'
 to the PKG_CONFIG_PATH environment variable
 No package 'xorg-macros' found
 checking whether make supports nested variables... (cached) yes
 checking for floor in -lm... yes
 checking for XRANDR... configure: error: Package requirements (xrandr >= 1.4 
xrender x11 xproto >= 7.0.17) were not met:
 Requested 'xrandr >= 1.4' but version of Xrandr is 1.3.2
 I hope I'm not doing wrong, thanks again,
 Makoto Fujiwara, 
 Chiba, Japan, Narita Airport and Disneyland prefecture.

Home | Main Index | Thread Index | Old Index