pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/48268: update cherokee to 1.2.103

The following reply was made to PR pkg/48268; it has been noted by GNATS.

From: "OBATA Akio" <>
Subject: Re: pkg/48268: update cherokee to 1.2.103
Date: Sat, 05 Oct 2013 22:24:45 +0900

 On Fri, 04 Oct 2013 13:45:00 +0900, Gianni D'Aprile 
<> wrote:
 > Update cherokee webserver to v1.2.103.  Package has to use master.tar.gz 
 > instead of versioned release tarball from github because versioned release 
 > is incomplete/broken (missing admin ui).
 1. It is impossible to call `master' as `1.2.103'.
 2. From RCS Id of Makefile, you are based in too old version, so some matters 
had been lost.
 3. Then, SUBST python2 is wrong, it should be handled with REPLACE_PYTHON.
     (anyway, ${PYTHONBIN} should be used instead of plain `python')
 4. I cannot find the reason why autoconf/automake are required.
 5. PAM is handled in, no need to included in Makefile.
 6. Why databases/rrdtool must be buildlinked?
 7. ffmpeg is added to PLIST_VARS, but whole conditional PLIST had been lost,
     so what is it?
 OBATA Akio /

Home | Main Index | Thread Index | Old Index