pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/48154: pkgsrc/lang/gcc (gcc 2.95.3) is not built on NetBSD/i386 6.1

The following reply was made to PR pkg/48154; it has been noted by GNATS.

From: David Holland <>
Subject: Re: pkg/48154: pkgsrc/lang/gcc (gcc 2.95.3) is not built on
 NetBSD/i386 6.1
Date: Tue, 3 Sep 2013 05:26:08 +0000

 On Sat, Aug 31, 2013 at 07:15:01AM +0000, Ryo ONODERA wrote:
  >> pkgsrc is not just for current NetBSD releases and gcc-2.x is the latest
  >> GCC for some platforms.
  >> For example, it is useful to analyze a issue whether it is particular issue
  >> for such platforms or gcc-2.x.
  > Yes.
  > FeeMiNT's official compiler is gcc 2.95.3.
  > FreeMiNT has some issues with pkgsrc.
  > To clarify what is the cause, I want to use gcc 2.95.3.
  > pkgsrc-2013Q2 release announcement has FreeMiNT as supported platform,
  > and I am improving FreeMiNT support now (see e-mails in tech-pkg@).
 Okay, but that doesn't require running gcc 2.95 on NetBSD, does it?
 It isn't going to work unless either we re-add gcc2 stdarg support to
 NetBSD (that is going to be a tough sell) or someone implements the
 __builtin_va_* stuff for gcc 2.95. I have no idea how hard that would
 You'll also find that gcc 2.95 doesn't compile with recent gcc,
 although maybe we have patches for that in pkgsrc already.
  > Deleting the official compiler of supported platform is very bad idea.
 Surely FreeMiNT doesn't depend on the copy in pkgsrc...
 David A. Holland

Home | Main Index | Thread Index | Old Index