pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/48116 (multimedia/ffmpeg / ffplay do not build)

The following reply was made to PR pkg/48116; it has been noted by GNATS.

From: Stefan Schaeckeler <>
Subject: Re: pkg/48116 (multimedia/ffmpeg / ffplay do not build)
Date: Sun,  1 Sep 2013 12:33:14 -0700 (PDT)

 >  Let's go back a step. The code definitely does not try to add
 >  --disable-asm when building with gcc-4.3.3. Why is it needed for you?
 >  What are the symptoms you see?
 With gcc 4.3.3 + not --disable-asm, I run into
 Somehow it looks to me that sucess/failure to compile ffmpeg's inline 
assembler code depends on a combination of the gcc version and gcc flags. This 
makes it a quite fragile package for pkgsrc.
 I can build ffmpeg successfully:
 - gcc 4.3.3 (native) + --disable-asm
 - gcc 4.5 (from pkgsrc) + without --disable-asm

Home | Main Index | Thread Index | Old Index