pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/48050: esh-mode.el from pkg esh conflicts with emacs eshell

>Number:         48050
>Category:       pkg
>Synopsis:       esh-mode.el from pkg esh conflicts with emacs eshell
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Jul 12 13:35:00 +0000 2013
>Originator:     Memnon Anon
>Release:        6.0.1
NetBSD sdf 6.0.1 NetBSD 6.0.1 (SDF61) #0: Mon Jan 16 18:14:29 UTC 2012  
root@ol:/src/sys/arch/amd64/compile/SDF61 amd64
Package esh provides an elisp file esh-mode.el which is being installed to 

It seems that mode is no longer functional (tested with 
emacs 23.4 & 24.3) ->
M-x load-file /usr/pkg/share/emacs/site-lisp/esh-mode.el ->
"Symbol's value as variable is void: shared-lisp-mode-map"

Even worse: That file shadows eshell, bundled with emacs, so 
that starting eshell on a system where package esh is installed 
will result in the error above.

See also:
(Gentoo had the same problem and fixed it)
Seems to be the same problem, but the reporter fixed it by deleting 
the file manually.
1.) Install package esh
2.) Start emacs
3.) M-x eshell
Several Options AFAICT:

A) The mode seems no longer functional. Remove it from the package.
B) Instead (provide 'esh), use (provide 'esh-mode) or similar so that it 
   no longer conflicts with eshell.
C) If you want to ship the file (although it is broken) and don't
   want to modify it, put it someplace outside the emacs load-path.
   I don't know netbsd well enough so far, in debian, that would 
   probably be /usr/share/doc/esh-mode/examples/ .

Home | Main Index | Thread Index | Old Index