pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/47698: sysutils/py-notify fails on build

>Number:         47698
>Category:       pkg
>Synopsis:       pkg
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Mar 27 14:55:00 +0000 2013
>Release:        NetBSD 6.0.1
System: NetBSD 6.0.1 amd64
Architecture: amd64
Machine: amd64
        Fails during build due to not having GtkWidget declared. Including
<gtk/gtkwidget.h> still fails due to passing too many arguments to
        cd pkgsrc/sysutils/py-notify; bmake
        We could fix this outdated, unsupported, and unmaintained version of
py-notify, or update it to the latest stable:

        "Releases in 0.1 development branch are still available on a separate 
for historical purposes. There is no reason to use them in production: current
stable 0.2 is both bug-free and faster, and more features can be found in 0.3
development releases."

This can't be updated during the freeze due to inputmethod/ibus depending on
it and 26 packages depending on that. At least it works with the version of
libnotify that we're still maintaining. hplip depends on this package, so it
is a bit important to me.

Home | Main Index | Thread Index | Old Index