pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/47300: pkg-config --atleast-version is broken

The following reply was made to PR pkg/47300; it has been noted by GNATS.

From: Thomas Cort <>
Subject: Re: pkg/47300: pkg-config --atleast-version is broken
Date: Mon, 18 Feb 2013 20:48:32 -0500

 I looked into this a bit more. Most of the results I got when
 searching this error message on Google pointed to lib/charset.alias.
 That file is generated by the libcharset which is included in the
 converters/libiconv package. On Minix, the generated file was empty
 because the generation script doesn't know about Minix yet. I taught
 the generator (./libcharset/lib/config.charset) about Minix and the
 generated file now has the line "646 ASCII" which fixes pkg-config's
 complaining. Now pkg-config works as expected. I realize that this
 doesn't really solve the issue on NetBSD, but it might give you some
 ideas on places to look for clues.

Home | Main Index | Thread Index | Old Index