pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/47519: pkgsrc/www/w3m fails to build if pre-7.2 boehm-gc is installed.

>Number:         47519
>Category:       pkg
>Synopsis:       pkgsrc/www/w3m fails to build if pre-7.2 boehm-gc is installed.
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Feb 01 06:35:01 +0000 2013
>Release:        NetBSD 6.99.5
System: NetBSD 6.99.5 NetBSD 6.99.5 (GENERIC) #0: Wed Apr 
25 03:00:33 JST 2012
Architecture: x86_64
Machine: amd64

# I've experienced this on pkgsrc-2012Q4 branch but I guess
# the situation is same on -current as far as reading the source.

w3m in pkgsrc fails to build if pre-7.2 boehm-gc is installed
from pkgsrc.  Here is build log message:

===> Installing in www/w3m
=> Bootstrap dependency digest>=20010302: found digest-20080510
=> Checksum SHA1 OK for w3m-0.5.3.tar.gz
=> Checksum RMD160 OK for w3m-0.5.3.tar.gz
===> Installing dependencies for w3m-0.5.3nb6
=> Build dependency gmake>=3.81: found gmake-3.82nb1
=> Full dependency perl>=5.0: found perl-5.16.2nb2
=> Full dependency boehm-gc>=6.6nb1: found boehm-gc-7.1nb4
===> Overriding tools for w3m-0.5.3nb6
===> Extracting for w3m-0.5.3nb6
main.o: In function `main':
main.c:(.text+0xadc7): undefined reference to `GC_get_warn_proc'
gmake: *** [w3m] Error 1
*** Error code 2



Prepare system installed old boehm-gc from pkgsrc.  Run make update
in pkgsrc/www/w3m.


The API GC_get_warn_proc used by patches/patch-ab exists only in
boehm-gc 7.2.  So, make w3m packages to require boehm-gc 7.2
or later.

Home | Main Index | Thread Index | Old Index