pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/47489: perl does not build on NetBSD-current

On Jan 22,  6:00pm, ( wrote:
-- Subject: pkg/47489: perl does not build on NetBSD-current

|       The lang/perl5 package does not build under NetBSD-current.
|       The errors are related to getproto*_r and getserv*_r functions.
|         NetBSD does not declare the getserv*_r or getproto*_r functions
|         in any header files, but it does provide private implementations
|         in libc.  perl's Configure script seems to find the private
|         implementations but be confused about the types of the
|       arguments.

The previous versions of perl were fixed by disabling those functions
in the configure script.


Home | Main Index | Thread Index | Old Index