pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/45943 (Circular dependency of texlive packages)

Synopsis: Circular dependency of texlive packages

Responsible-Changed-From-To: pkg-manager->gdt
Responsible-Changed-When: Wed, 05 Dec 2012 21:41:21 +0000
As I read this, pkg_rr chose to replace tex-tetex first, which is correct
as texlive requires tetex. But the new tetex conflicts with the old
texlive.  So this isn't a pkg_rr bug.  At best, it's a failure to
use some new multi-package-replace feature that doesn't yet exist.
So I propose to close this PR, and ask that if you would like to
continue working on this taht you either:
  submit a case where make replace fails and you think it shouldn't,
  without using pkg_rr

  submit a case where pkg_rr is doing things in the wrong order, or fails 
  to compute an order that it should

I'm not saying your problem is invalid, but rather than pkgsrc does not 
support in-place updates when there are dependencies and conflicts
like this.

State-Changed-From-To: analyzed->feedback
State-Changed-When: Wed, 05 Dec 2012 21:41:21 +0000
(see responsible change field)

Home | Main Index | Thread Index | Old Index