pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/47249: sysutils/cfengine3 upgrade

>Number:         47249
>Category:       pkg
>Synopsis:       sysutils/cfengine3 upgrade
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Mon Nov 26 15:10:00 +0000 2012
>Originator:     Francis GUDIN
>Release:        DragonFly
DragonFly v3.2.0.20.gccc37-RELEASE

This is an upgrade for CFEngine, from 3.1.4 to 3.3.8 (a doc/TODO item).

Among changes, the DB dependency went from db4 to tokyocabinet: an alternative 
could be qdbm for platforms where tokyocabinet would be difficult/impossible to 
On the good news side, installation paths have been reworked, and this is much 
more pkgsrc friendly now with configure's --enable-fhs.

Let me know if examples (units and basic policy) and other doco don't fit with 
pkgsrc habits: i wasn't too sure of my choices either.

Built and (lightly) tested with 2 DragonFly hosts (my master node and a client, 
both previously running a locally built 3.2.3): no issue so far.


Patch can be fetched from

Thanks in advance,

Home | Main Index | Thread Index | Old Index