pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/46867 (Tk 8.5.12 does not build on Solaris)

Maybe someone cares to answer my questions? I do actually need a working Tk, we still have some legacy applications that use it.

I simply installed the package without the patches, i.e. I installed less header files and shared objects with a different naming scheme. The only change I needed for some depending packages was to remove the pkgsrc addition in lang/tcl-expect that creates a static library of libexpect, because the same handcrafted code was removed from Tk.

Observing the rule "If it ain't broken, don't fix it", I ask again to consider trimming down Tcl and Tk and remove the majority of the changes pkgsrc has added to these two packages.

 Jörn Clausen                    
 Universität Bielefeld

Home | Main Index | Thread Index | Old Index