pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/46739 (security/gnutls does not build on Solaris 10)

  Hmmm... it appears my gcc46 build is using /usr/sfw/bin/gas I don't
  know how that happened.

Because someone forced you to use it, see lang/gcc46/Makefile:

# Determine whether to use binutils
.if ${OPSYS} == "SunOS"
CONFIGURE_ENV+=         OBJDUMP=/usr/sfw/bin/gobjdump
CONFIGURE_ARGS+=        --without-gnu-ld --with-ld=/usr/ccs/bin/ld
. if !exists(/usr/sfw/bin/gas)
CONFIGURE_ARGS+=        --without-gnu-as --with-as=/usr/ccs/bin/as
. else
CONFIGURE_ARGS+=        --with-gnu-as --with-as=/usr/sfw/bin/gas
. endif

  FWIW I do think you patch is reasonable and should be applied if we
  don't find another quick resolution.

Someone (i.e. someone with more knowledge about either assembler or TLS than me) should probably take this upstream. Although this is a GNU project, unconditionally confining it to one assembler is a little bit shortsighted.

 Jörn Clausen                    
 Universität Bielefeld

Home | Main Index | Thread Index | Old Index