pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/46754: Eclipse does not start

>Number:         46754
>Category:       pkg
>Synopsis:       Eclipse does not start
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jul 29 22:40:00 +0000 2012
>Originator:     Germain Le Chapelain
>Release:        NetBSD-current
NetBSD germ 6.99.8 NetBSD 6.99.8 (germ) #0: Fri Jun 29 20:12:38 UTC 2012  
root@:/usr/obj/sys/arch/amd64/compile/germ amd64

I tried to install both the version of eclipse in




and all I get when I try starting it up is a disapointing 

/usr/pkg/bin/eclipse: ./eclipse: not found

I tried running the binary referenced in the script and got

bash: /usr/pkg/eclipse/eclipse: No such file or directory

when I try debugging it it, it doesn't work either:

bash-4.2$ gdb /usr/pkg/eclipse/eclipse
GNU gdb (GDB) 7.3.1
Reading symbols from /usr/pkg/eclipse/eclipse...done.
(gdb) break main
Breakpoint 1 at 0x8048daa: file ../eclipseMain.c, line 99.
(gdb) run
Starting program: /usr/pkg/eclipse/eclipse 
exec: /usr/pkg/eclipse/eclipse: not found
During startup program exited with code 127.

I tried to put a break point in an hypotetical `exec' function, but let's face 
it: I have no clue what I'm doing.

Is there somewhere I could start looking at ? 



Home | Main Index | Thread Index | Old Index