pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/46238 (multimedia/xine-lib fails to build on NetBSD 5.1_STABLE/amd64)

On Thu, 22 Mar 2012 13:03:51 +0000 (UTC) wrote:

> Synopsis: multimedia/xine-lib fails to build on NetBSD
> 5.1_STABLE/amd64
> State-Changed-From-To: open->feedback
> State-Changed-By:
> State-Changed-When: Thu, 22 Mar 2012 13:03:50 +0000
> State-Changed-Why:
> there is an autoconf check for that flag
> What does it report for you?

Not sure exactly what you are looking for, but config.log says:


It was created by xine-lib configure 1.2.1, which was
generated by GNU Autoconf 2.68.  Invocation command line was

  $ ./configure --with-w32-path=/usr/pkg/lib/win32 --disable-v4l
  --disable-real- codecs --disable-aalib --disable-opengl
  --prefix=/usr/pkg --build=x86_64--netbsd --host=x86_64--netbsd

configure:19690: result: yes
configure:19700: checking if cc supports
-Werror-implicit-function-declaration f lag
configure:19715: cc -c -g -O2 -I/usr/pkg/include -I/usr/include
-I/usr/pkg/inclu de/freetype2 -Werror-implicit-function-declaration
-DNDEBUG -D_REENTRANT -DXINE_ COMPILE -I/usr/pkg/include -I/usr/include
-I/usr/pkg/include/freetype2  -pthread conftest.c >&5
configure:19715: $? = 0
configure:19731: result: yes
configure:19740: checking if cc supports -Wstrict-aliasing=2 flag
configure:30352: result: yes
configure:30374: checking if cc supports -Wl,--no-undefined flag
configure:30385: cc -o conftest -g -O2 -I/usr/pkg/include
-I/usr/include -I/usr/ pkg/include/freetype2 -Wall -Wchar-subscripts
-Wnested-externs -Wcast-align -Wmi ssing-declarations
-Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer- sign
-Wformat=2 -Wno-format-zero-length -Wformat-security
-Wstrict-aliasing=2 -W error=implicit-function-declaration -DNDEBUG
-D_REENTRANT -DXINE_COMPILE -I/usr/ pkg/include -I/usr/include
-I/usr/pkg/include/freetype2  -pthread  -g -L/usr/pkg /lib
-Wl,-R/usr/pkg/lib -L/usr/lib -Wl,-R/usr/lib -Wl,--no-undefined
conftest.c >&5 cc1: error: unrecognized command line option
"-Werror=implicit-function-declarat ion" configure:30385: $? = 1
configure: failed program was:
| /* confdefs.h */

I don't know why the first check succeeds when the second one fails... 
Does this help?  If I've not given you what you were looking for,
please poke me in the right direction..



Greg Oster

Home | Main Index | Thread Index | Old Index