pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/46151: gnash not building

>Number:         46151
>Category:       pkg
>Synopsis:       gnash not building
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Mar 07 14:25:02 +0000 2012
>Originator:     Martin Husemann
>Release:        NetBSD 6.99.3
The NetBSD Foundation, Inc.
System: NetBSD 6.99.3 NetBSD 6.99.3 (NIGHT-OWL) #62: Wed Feb 
22 09:54:23 CET 2012 
Architecture: x86_64
Machine: amd64

Trying to build gnash from pkgsrc-current after updating all packages
fails with:

Making all in libdevice
gmake[2]: Entering directory 
  CXX    libgnashdevice_la-DeviceGlue.lo
  CXX    libgnashdevice_la-X11Device.lo
x11/X11Device.cpp:41:3: error: #error "This file needs X11"
In file included from x11/X11Device.cpp:44:0:
x11/X11Device.h:35:3: error: #error "This file needs X11"
gmake[2]: *** [libgnashdevice_la-X11Device.lo] Error 1
gmake[2]: Leaving directory 
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/pkgobj/multimedia/gnash/work/gnash-0.8.10'
gmake: *** [all] Error 2
*** Error code 2

I am using native Xorg.

just fails for me, no idea


Home | Main Index | Thread Index | Old Index