pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/46017: pango build weiredness

>Number:         46017
>Category:       pkg
>Synopsis:       building pango on sparc64 emits and ignores serious errors
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Feb 13 15:35:00 +0000 2012
>Originator:     Martin Husemann
>Release:        NetBSD 5.99.65
The NetBSD Foundation, Inc.
System: NetBSD 5.99.65 NetBSD 5.99.65 (MODULAR) #140: 
Mon Feb 13 07:52:19 CET 2012
Architecture: sparc64
Machine: sparc64

When building pango on a -current sparc64 machine I noticed lots of messages
like this:

  GISCAN GLib-2.0.gir
/usr/include/sparc/mcontext.h:168: syntax error, unexpected identifier, 
expecting ',' or ';' in ' __asm volatile("mov %%g7, %0" : "=r" (__tmp));' at 'o'
g-ir-scanner: GLib: warning: 720 warnings suppressed (use --warn-all to see 


Just build pango-1.29.4nb2 and closely watch the log (the build does not


Home | Main Index | Thread Index | Old Index