pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/45888: graphics/SDL_image (1.2.12) libtool usage error

>Number:         45888
>Category:       pkg
>Synopsis:       graphics/SDL_image (1.2.12) libtool usage error
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jan 30 11:55:00 +0000 2012
>Originator:     Robert Elz
>Release:        NetBSD 5.0   (pkgsrc current 2012-01-30)
        Prince of Songkla University
System: NetBSD 5.1 NetBSD 5.1 (JADE-1.12-20101117) #5: Wed 
Nov 17 05:30:55 ICT 2010 i386
Architecture: i386
Machine: i386
        Building graphics/SDL_image (that is, attempting to build)
        on NetBSD 5.0 (i386) results in a libtool usage (or error) message...

        I use pkg_comp with NetBSD 5.0 release sets installed, and libkver
        to simulate a genuine NetBSD 5.0 environment.  I use native X11,
        and USE_DESTDIR=no.

        In that environment, "make package" (via pkg_comp) of graphics/SDL_image
        results in ...

libtool: compile:  cc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" 
-DPACKAGE=\"SDL_image\" -DVERSION=\"1.2.12\" -DLOAD_JPG=1 -DLOAD_PNG=1 
-I/pkg_comp/obj/pkgsrc/graphics/SDL_image/5/.x11-buildlink/include -O2 
 MD -MP -MF .deps/IMG_webp.Tpo -c IMG_webp.c -o IMG_webp.o >/dev/null 2>&1
mv -f .deps/IMG_webp.Tpo .deps/IMG_webp.Plo
/bin/sh ./libtool    --mode=link gcc  -O2 -I/usr/pkg/include 
-I/usr/X11R7/include -I/usr/include -I/usr/pkg/include/SDL -D_GNU_SOURCE=1 
-D_REENTRANT -D_THREAD_SAFE  -no-undefined               -release 1.2    
-version-info 8:4:8 -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/X11R7/lib 
-L/usr/lib -Wl,-R/usr/lib -Wl,-R/usr/X11R7/lib -o -rpath 
/usr/pkg/lib IMG.lo IMG_bmp.lo IMG_gif.lo IMG_jpg.lo  IMG_lbm.lo IMG_pcx.lo 
IMG_png.lo IMG_pnm.lo IMG_tga.lo  IMG_tif.lo IMG_xcf.lo IMG_xpm.lo IMG_xv.lo 
IMG_webp.lo    -L/usr/pkg/lib -Wl,-rpath,/usr/pkg/lib -lSDL -lpthread
libtool: link: unable to infer tagged configuration
libtool: link: specify a tag with `--tag'
*** Error code 1

make: stopped in /pkg_comp/obj/pkgsrc/graphics/SDL_image/5/SDL_image-1.2.12
*** Error code 1

make: stopped in /usr/pkgsrc/graphics/SDL_image
*** Error code 1


        No idea, I don't even know what that means (or what a --tag would
        do, or where it should be put).

Home | Main Index | Thread Index | Old Index