pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/45886: libglade does not build 'libtool: link: `/usr/pkgsrc/devel/libglade/work/.buildlink/lib/' is not a valid libtool archive'

>Number:         45886
>Category:       pkg
>Synopsis:       libglade does not build 'libtool: link: 
>`/usr/pkgsrc/devel/libglade/work/.buildlink/lib/' is not a 
>valid libtool archive'
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Sun Jan 29 16:00:00 +0000 2012
>Originator:     Arthur
>Release:        5.99.6
NetBSD thunder 5.99.60 NetBSD 5.99.60 (GENERIC) #0: Mon Jan 16 20:19:16 UTC 

When trying to build bittorrent-gui, it stops while building libglade. 
Obviously, the same occurs when I try to build directly from 
/bin/sh ../libtool --tag=CC   --mode=link gcc  -O2 -I/usr/pkg/include 
-I/usr/include -I/usr/pkg/include/freetype2 -Wall -std=c9x -version-info 0:7:0 
-export-symbols-regex "^[^_].*" -no-undefined -L/usr/pkg/lib -Wl,-R/usr/pkg/lib 
-L/usr/lib -Wl,-R/usr/lib -o -rpath /usr/pkg/lib glade-init.lo 
glade-xml.lo glade-parser.lo glade-gtk.lo -Wl,-R/usr/pkg/lib -pthread 
-L/usr/pkg/lib -lxml2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 
-lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage 
-lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 
-lm -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 
-lglib-2.0 -lintl
libtool: link: 
`/usr/pkgsrc/devel/libglade/work/.buildlink/lib/' is not a 
valid libtool archive
gmake[2]: *** [] Error 1
gmake[2]: Leaving directory 
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/pkgsrc/devel/libglade/work/libglade-2.6.4'
gmake: *** [all] Error 2
*** Error code 2

make: stopped in /usr/pkgsrc/devel/libglade
*** Error code 1

make: stopped in /usr/pkgsrc/devel/libglade

cd /usr/pkgsrc/devel/libglade
sudo make install


Home | Main Index | Thread Index | Old Index