pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/45638: devel/nspr headers define FREEBSD, break LibreOffice

>Number:         45638
>Category:       pkg
>Synopsis:       devel/nspr headers define FREEBSD, break LibreOffice
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Nov 21 19:45:00 +0000 2011
>Originator:     Francois Tigeot
>Release:        DragonFly 2.13
DragonFly 2.13-DEVELOPMENT DragonFly 
v2.13.0.376.ga535b-DEVELOPMENT #33: Mon Nov 21 12:50:13 CET 2011  
Recent versions of LibreOffice use headers provided by devel/nss and devel/nspr.

These packages use patches from devel/xulrunner to treat DragonFly as FreeBSD 
and define the FREEBSD macro.

LibreOffice also uses the FREEBSD macro internally, which causes it to try to 
compile FreeBSD-specific code and results in a build failure on DragonFly 
Try to build recent development versions of LibreOffice on a DragonFly system.
I believe it is time to stop treating DragonFly as FreeBSD in devel/xulrunner.

Home | Main Index | Thread Index | Old Index