pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/45624: Building new pkg_install fails

>Number:         45624
>Category:       pkg
>Synopsis:       Building new pkg_install fails
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Nov 17 14:25:00 +0000 2011
>Originator:     Havard Eidnes
>Release:        NetBSD 5.0.1
System: NetBSD 5.0.1 NetBSD 5.0.1 (GENERIC) #0: Thu Jul 
30 03:29:26 UTC 2009
Architecture: hp300
Machine: m68k
        Trying to build pkg_install from pkgsrc-2011Q3 fails with this
        error message:

                 /bin/sh                         ./configure --disable-shared 
--disable-bsdtar           --disable-bsdcpio --without-expat --without-xml2     
configure: error: cannot find install-sh,, or shtool in 
build/autoconf "."/build/autoconf
*** Error code 1

make: stopped in /usr/pkgsrc/pkgtools/pkg_install

        This apparently happens when trying to build the libarchive
        bits for pkg_install.
        Try to build pkg_install from 2011Q3 on a machine with no
        packages installed.  Watch it fail.
        I attempted a workaround by copying install-sh from
        work/libnbcompat/ to work/libarchive/, but that did not work.

Home | Main Index | Thread Index | Old Index